Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 14-08-2017   #1
Join Date: May 2015
Posts: 15
Thanks: 0
Trader Rating: 0
Sweden 
Punto 188 2001 speed sensor issues (jumping up and down, not showing correct speed)

When I start to drive at low speeds the car shows the speed correctly. The hand trembles a little bit but seems to work. For example, when I go on the freeway and get up on higher speeds the hand can go down to 0 or jump between for example 20 km/h and 60 km/h. Sometimes it just rests at 0. However, if I press down the break or both the "window up" buttons the speed is shown correctly. Pressing just one "window up" doesn't work. I can see the hand reacts to the press but it's not until I press both it shows the correct speed.
I had another speed sensor in my car that broke and didn't show the speed at all but the mechanic took an old one he had lying around and this is what's happening now.

What could this be?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Moskis is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Punto sporting speed sensor Giedriusss Punto (Mk2/2b) 6 12-06-2014 19:48
(G) is my speed correct? Azzam Punto (Mk2/2b) 22 18-12-2011 05:30
(T) Speed sensor/starting issues danmarie30 Punto (Mk2/2b) 4 28-12-2009 20:49
(G) Punto sporting 2001 6 speed ECU for sale sporting_adz Punto (Mk2/2b) 1 20-03-2008 14:05