Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 18-03-2017   #16
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Temp sensors seem ok

Fuel rail pressure 1090 kpa with ignition in and car not running
And around 38,000 kpa when running in tick over.

Does this sound normal?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 19-03-2017   #17
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,435
Thanks: 533
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by thunnisett View Post
Starter motor changed but made no difference.

Have the injectors tested Monday (leak back test)
Tried the 2nd earth cable?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 19-03-2017   #18
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,435
Thanks: 533
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by thunnisett View Post
Starter motor changed but made no difference.

Have the injectors tested Monday (leak back test)
Tried the 2nd earth cable?

If youve got good rail pressure whilst cranking..then no point paying for injector test.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 20-03-2017   #19
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Injectors were fine. The mechanic suspects hp fuel pump.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 20-03-2017   #20
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,435
Thanks: 533
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by thunnisett View Post
Injectors were fine. The mechanic suspects hp fuel pump.
What the same mechanic who was convinced it was the starter..??

Cranking speeds equates to pump speed : rail pressure

Plenty of ways to test this without spending a LOT of money
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 20-03-2017   #21
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Sorry. Let me clarify.

The starter motor was replaced as it was turned over slowly in occasions so this needed doing anyway but was hoping it was causing the other issue.

Spoke to me basic again and I got it wrong. He said the fuel pump should be ok. And suspects first place to check is replacing the cam shaft sensor.

Will test cranking pressure tonight just to double check
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 20-03-2017   #22
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Ok. Stuck now!

Changed starter motor
Tested battery
Injectors tested and ok
Fuel pressure good on cranking
No fault codes
Runs perfect once started
Intermittent starting problem, Just takes around 10 seconds to start, turns over fine but struggles to pick up

Mechanic said possible a sensor.

I was thinking camshaft sensor or crankshaft sensor?

What's everyone's opinions?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 20-03-2017   #23
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 4,080
Thanks: 173
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: 1.9 JTDM trouble starting - Please help

Glow plugs.
Likes thunnisett liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Peter Pick-Up is offline Reply With Quote Quote 
Old 20-03-2017   #24
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

They were replaced in 2015 and wouldn't it throw up an error code?

Car continues to have trouble starting even after 30 mins of driving.

Would you still think it's worth changing them?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 20-03-2017   #25
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by varesecrazy View Post
Tried the 2nd earth cable?

If youve got good rail pressure whilst cranking..then no point paying for injector test.
Where the 2nd earth cable located?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Old 21-03-2017   #26
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 4,080
Thanks: 173
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: 1.9 JTDM trouble starting - Please help

Quote Originally Posted by thunnisett View Post
They were replaced in 2015 and wouldn't it throw up an error code?

Car continues to have trouble starting even after 30 mins of driving.

Would you still think it's worth changing them?
Even new ones can go bad.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Peter Pick-Up is offline Reply With Quote Quote 
Old 21-03-2017   #27
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,435
Thanks: 533
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Quote Originally Posted by thunnisett View Post
Where the 2nd earth cable located?
look here in the GP section FAQ's,
http://www.fiatforum.com/grande-punt...in-thread.html

the internals of the main earth cables can break down.. looking fine..but unable to support large transfer loads..,

a test is to use a "jump-lead" as an additional earth cable,
if it behaves better buy a NEW lead.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 21-03-2017   #28
Join Date: Mar 2017
Posts: 16
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 1.9 JTDM trouble starting - Please help

Thanks

It's not that then as I used jump leads yesterday to see if it made any difference and it didn't.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thunnisett is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 2008 1.6 JTDM Starting Woes Most Easterly Pandas Bravo 3 28-12-2013 13:59
(T) Trouble Starting Funkstar De Luxe Barchetta 16 13-02-2009 10:09
(G) Trouble Starting ap07aaa Bravo 13 18-12-2008 18:21
(T) Trouble starting!!!!! Astle10 Punto (Mk2/2b) 1 30-11-2008 23:39
(T) trouble starting alanstalin Punto (Mk2/2b) 4 17-08-2008 15:14