Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 23-01-2015   #1
Join Date: Oct 2005
Posts: 44
Thanks: 1
Trader Rating: 0
United Kingdom 
Stilo 1.9 jtd car security loose connection fault

Bought a stilo for the other half and finally just got it on the road.
I've been running it around myself for last month as I don't trust it, I keep getting (car security loose connection fault) basically it never fails to start from cold, after a good run and its upto temperature if I switch it off at the level crossings while waiting for a train or when we have just filled up with fuel it won't start. It's done it around 5 times in 3 weeks covering 1000 miles. It starts after around 5 mins or less of trying after its packed in.

Its always happened when it's switched off for a short period of time and never after been sat for a while.

I've checked over the wiring and connectors in the engine bay fuse box. I've swapped the engine bay fuse box and relays for a good spare one I had and checked wire connections into engine bay Ecu, I've also tried spare key I have but still get the same problem.

Has any one any other ideas what to check next?

Many thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

dalemultiwagon is offline Reply With Quote Quote 
Old 24-01-2015   #2
Join Date: Jul 2008
Location: Telford
Posts: 59
Thanks: 1
Trader Rating: 0
uktrucker has donated!
United Kingdom 
Re: Stilo 1.9 jtd car security loose connection fault

May be crank sensor.
Mine would start ok from cold as you say but for me the car would sometimes just cut out and not restart until left for between 5-20 mins and then be ok again for a while. Best option is to get someone to do quick diagnostic as it should throw up this type of error. Think the security error and loose conection a second unrelated issue as stilo can be very tempromental if battery is not so good or earth is not good.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

uktrucker is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Loose Connection Car security Failure stevea199 Stilo 10 17-09-2014 07:27
(T) Car Security, Loose Connection - I thought i had fixed this! stilotoby Stilo 6 10-04-2012 13:52
(T) Stilo 1.6 Dynamic Engine fault/loose connection BenCooper Stilo 5 24-06-2011 21:45
fiat stilo 1.9 jtd loose connection fault domingos alves Newbie Central 0 27-11-2010 17:50
(T) airbag loose,connection,security failure and something bout watter temp (missfire) madyotto Stilo 24 17-08-2010 17:38