Register Login
Mr. FIAT
Reply
 
Thread Tools
Old 07-01-2009   #61
Stilolos???
 
chicken_chau_mein's Avatar
Join Date: Jun 2007
Location: Bolton
Posts: 505
Thanks: 10
Trader Rating: 0
chicken_chau_mein has donated!
United Kingdom 
Re: Stilo Instrument Panel not working!!!

Glad you got it working again. My brother suggested driving around with the fuse removed thinking it wouldn't register the distance travelled on the tachometer... Nice idea but i'd rather know how much fuel i have left and the speed i'm doing...

The problem may of just been that the contacts had frozen over.
__________________
chicken_chau_mein is offline Reply With Quote Quote 
Old 08-01-2009   #62
Join Date: Jan 2009
Posts: 1
Thanks: 0
Trader Rating: 0
Angry Stilo Disco dashboard

Hey i'm new to all this and REALLY need some advice.

I have an issue with the dashboard - the whole thing is out - no lights - no speedo/petrol guage - NOTHING!
But everyday it comes on/off/on/off and it's really doing my head in.
It makes a strange whirring noise - even when there are no keys in the ignition lol! It's getting really irritating!

I'm wondering if anyone knows what this is? Really don't want to take it to a fiat garage as i just don't have the cash just now.

Any help is appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Imcharming is offline Reply With Quote Quote 
Old 08-01-2009   #63
Join Date: Aug 2008
Location: Ayrshire
Posts: 646
Thanks: 28
Trader Rating: 0
United Kingdom 
Re: Dashboard dials all dead!

Had this problem a few months ago, two things fixed it and it has not returned.

1. Check the earth connection for the instruments, this is located on the off side inner front wing, near the cambelt cover, this often gets ignored to be cleaned and re greased. The earth wire is normally tightened with a nyloc nut.

2. If you have access to an Examiner, check for fault codes and delete them.
__________________
Current Own : 2008/08 Alfa Romeo 159 Q4
Previous Fiats :
2008/57 Fiat Multipla 1.9 Multijet 140 bhp Eleganza
2005/55 Fiat Stilo Multiwagon 1.9 JTD Dynamic.
2005/55 Fiat Croma 1.9 Mjet 16v Eleganza
FiatFleetFamily is offline Reply With Quote Quote 
Old 11-11-2009   #64
Join Date: Feb 2009
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Dashboard dials all dead!

Happened to me two weeks ago. I was setting off to take the car (Multiwagon 2004 69k miles) in for a timing belt replacement and noticed the instrument cluster was dead. Asked the garage if they'd have a look. When I got the car back they said they couldn't find any fault codes on the computer and they'd checked all the relevant fuses.

I logged in here and checked out what everyone was advising. It seemed the cluster was dead after I'd gone through all the fuses again and taken the cluster out to check the connection.

My local dealer said they'd have a look at it if I paid them 60. I was tempted because I was driving a car with no instruments, but when I got home I found clusterrepairsuk through google. I emailed and they gave me a quote of something like 135 plus VAT.

Long and short is I sent it off last Thursday and got it back today after work. Connected it up and it's working fine with original mileage and so on. Had to reset date and time but well...

The final cost was 159.85 including VAT and courier. I had already paid Royal Mail 8.85 to send it next day guaranteed.

I think it's a pretty good deal compared to buying new, and I was nervous about buying from the scrappy and having to get the mileage reset.

Anyway, thought it was worth letting folks know. It's just another option.

Finally, I have absolutely nothing to do with cluster repairs uk. Do all your own research (fuses, connections etc) first, or get a used unit like others have done if you prefer. For all I know cluster repairs plugged it in and pressed a button and charged me 160 for it Also, their website says they give a two year guarantee but thre paperwork I got back today says 12 months.

Still happy though.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

cos is offline Reply With Quote Quote 
Old 02-12-2009   #65
Join Date: Jan 2008
Location: Navan
Posts: 12
Thanks: 0
Trader Rating: 0
Ireland 
Re: Dashboard dials all dead!

Hello, I've started to have this problem also today.
Recently took the wiper motor + assembly out to fix a broken push rod. Put it all back together, including the scuttle and rubber seal. Washed the car.
Now every time i start the car, 5 mins after, all lights in dash go out. Wirring noise, and they all come back.

Where to start? Earth problem? Relay + Fuse box under battery cover?

Car works perfectly but no display lights (even radio and heater lights down) and all instruments down to 0.000, can't see clock, but when it all comes back after 'Check OK' the clock was at the right time?

Can anyone help?

FiatFleetFamily - What did you do first to get dashboard back running?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

navan_stilo is offline Reply With Quote Quote 
Old 02-12-2009   #66
Join Date: Jan 2008
Location: Navan
Posts: 12
Thanks: 0
Trader Rating: 0
Ireland 
Re: Stilo Instrument Panel not working!!!

Mike295

I have the same problem. Washed the car yesterday. This morning, cold, started car, 5 mins and all the lights went out. Noise, then all warning lights on, then 'Check OK' and back to normal. This happend 2 times just after leaving for work.
Happened again on way home.

Where shall i start, earth straps, fuses or see if any damp is in the large 'flux capacitor' sitting on top of the battery (i think it's called the D4 connector)

Can you help?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

navan_stilo is offline Reply With Quote Quote 
Old 03-12-2009   #67
Give me back my HGT
 
Mike295's Avatar
Join Date: Jan 2009
Location: Moray
Posts: 5
Thanks: 0
Trader Rating: 0
Mike295 has donated!
United Kingdom 
Re: Stilo Instrument Panel not working!!!

Navan,

Since my previous post, I've not had a single dash fault. This may possibly coincide with my eventual replacement of the battery. Certainly you can't go wrong by setting about cleaning all electrical connections. Those around the battery are the most obvious, but having looked at other threads, there are some other fairly major 'earth' connections that are worth investigating too.

I've had many Fiat's down the years and luckily, coming from an electrical background, I've manage to sort most faults. I'd love to say that I have a definitve answer for this fault, but I don't. Coincidently, many of my other 'spurious' dash warnings stopped after the battery replacement, so in my case that was probably the root cause.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Mike295 is offline Reply With Quote Quote 
Old 12-12-2009   #68
Join Date: Jan 2008
Location: Belgrade
Posts: 37
Thanks: 0
Trader Rating: 0
Serbia 
Re: Stilo Instrument Panel not working!!!

Hi all I have similar problem.
Few day i have problem with dashboard go on and off.
But what happend to me, my stilo multiwagon jtd has nav+
and it is 2003 year and i have it last 2 year. I don't have code card for my connect nav+ and i have disconnected can nav+ from comp but when i want to change date and time i have to connect and i change time and date and seconds before it ask for code i press enter and change date and time, now my dashboard has reset date and time and i wanted to change that andi have found that my nav+ is no longer askking for master code. It is nice but my dash board little works and after some time it stop working. One thing is sure my car battery is in bad shape and need new one ( I know because if i let music go after i turn engine off after 30 min it is hard to start car. But what i don't know is where is grounding in engine. When my dashboard is off I can't setup time over my nav+.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

zocca is offline Reply With Quote Quote 
Old 13-12-2009   #69
Join Date: Jan 2008
Location: Belgrade
Posts: 37
Thanks: 0
Trader Rating: 0
Serbia 
Re: Stilo Instrument Panel not working!!!

Update.
Yesterday on my stilo multiwagon battery has finally died. I have put new one 72Ah ( 600A). Was original Fiat from 2003 ( 70Ah with 450A) When i changed battery every thing is working normally.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

zocca is offline Reply With Quote Quote 
Old 07-07-2010   #70
Join Date: Jul 2010
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Disco Dashboard

Quote Originally Posted by Deckchair5 View Post
Have you taken out the dash gauges and checked its electrical connector at the rear? It's quite easy to do
Hi, my name is Thomas, I am now a new member and own a 06 Stilo 1.6 16v Active sport. I have had troubles with my dashboard for quite some time and until today put the blame on a electronics fault. My reason for this is when removing fuse F57 and placing it back all of the dash dials would reset.

However a problem that has accured is my total milage has now disapeared and no longer registers new miles but the trip computer does. My rev counter no longer works either even when replacing the fuse in question.

So to the point, does anyone belive that if I was to clean the connections in the above quote will fix my situation or should I just get a new cluster which I have quoted 350+ just for the cluster. If I can clean it can anyone provide me with some diagrams or methods as I am a complete novice when it comes to car electronics.

Many thanks,
thomas220284
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

thomas220284 is offline Reply With Quote Quote 
Old 13-08-2010   #71
Join Date: Mar 2008
Location: Liverpool
Posts: 10
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Dashboard dials all dead!

Mine (54 JTD Multiwagon, 48K) has a problem that is identical to Imcharming's, down to the buzzing / whirring when no keys are in the ignition (during which the speedo and rev dials gently rise and fall!). Other things that happen are that the central interior light at the front stops working both as a courtesy light and when trying to switch it on - the central light at the back is OK at these times. On days like that, the dials go haywire when driving (0-6K revs several times a minute), the instrument lights go on and off with similar rapidity and accompanying whirring, and the dashboard clock either re-sets itself or the display remains static. At times like this, when starting the car, the dashboard is usually dead, other than two warning lights (see chicken_chau_mein).

The next day, though, there can be no sign of trouble whatsoever!

The problem isn't the instrument earth connection, and no fault codes are shown (checked by FIAT main dealer).

What makes sense to try first?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

tothemax is offline Reply With Quote Quote 
Old 13-08-2010   #72
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 696
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Dashboard dials all dead!

Lots of gauges going haywire, clocks,radio and ecu resetting, dashboard gauge backlights going off and dead dashboard apart from the safety warnings of airbag etc are a sure sign of voltage/ power loss. Stilo is programmed to shut down non essential items in event of low voltage

So I'd check battery and the battery and earth connections and dashboard gauge connections
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 13-08-2010 at 19:36.
Deckchair5 is offline Reply With Quote Quote 
Old 15-08-2010   #73
Join Date: Mar 2008
Location: Liverpool
Posts: 10
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Dashboard dials all dead!

Thank you Deckchair5.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

tothemax is offline Reply With Quote Quote 
Old 15-08-2010   #74
Join Date: Nov 2007
Posts: 37
Thanks: 1
Trader Rating: 0
United Kingdom 
Wink Re: Dashboard dials all dead!

Seems a common problem, I had to have the complete pinnacle replaced by fiat luckly it was in warranty at a cost of 400 from dealer I wouldn'tbe to happy, touch wood been ok since.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

colinsrea is offline Reply With Quote Quote 
Old 05-12-2013   #75
Join Date: Aug 2004
Posts: 122
Thanks: 2
Trader Rating: 0
United Kingdom 
Unhappy Re: Dashboard dials all dead!

Hi All,

So i've had the same problem with my car (1.2 52 plate). I work in central London so rarely drive the car during the week, and of late i've not needed the car during the weekends so its been stationary for about 4 weeks.

The care starts perfectly fine, and the majority of the electrics seem okay... heater, lights, indicators etc, but the dash is playing up. I've read through the thread and done the following:

1. swapped the battery today for a larger 72AH i think (its the largest that would fit)
2. Re seated the earth point near the bonnet stay after giving it a good clean out
3. Re-seated and brushed out all the socket type connections on the fuse panel around the battery
4. Checked the two fuses, F37 & F53, and they appear to be intact...

Nothing cleared the problem, but pulling fuses F37 and F53 caused various bits of the dash panel to light up, from fog lights, to left indicator etc.. but needles remained stationary.

I've not used contact cleaner yet as I don't have any at home, but will attempt to do so this weekend... but does anyone have any ideas what it could be? I'm assuming that with the cluster lighting up (albeit incorrectly) that the cluster is ok?? (please tell me if i'm being naive) Mileage on the car was around 68k at MOT a few months ago, so i'm not sure how easy it will be to get a cluster under this mileage...

Any help/pointers/guidance greatly appreciated.

Thanks

D.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

onfire_82 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Dead dashboard maccy Bravo / Brava 4 18-03-2008 11:13
(T) Dead Dashboard - Well, the important bits KeironO Marea 4 10-04-2006 11:01
(T) HGT dashboard dead! stevent Punto (Mk2/2b) 5 22-01-2006 09:32
(T) question on swapping dashboard dials... Bosch Punto (Mk2/2b) 1 28-10-2005 21:47
(T) Dashboard Dials Don't Work MarkH Marea 2 13-03-2004 03:09