Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 02-05-2008   #1
Join Date: Oct 2007
Posts: 5
Thanks: 0
Trader Rating: 0
stilo wipers, front and back not working

Hi All

I am in need of some urgent advice please.

The wipers on my stilo 1.2 16v have stopped working yesterday, front and back. The windsreen washers both work okay, so does the computer trip, i tried cleaning the front motor of its grease as recomended on the site here. I have a live feed at loom from the switch, fuse box, (fuse is okay) but there seems to be no live feed at the front motor. Are the two motors linked in any way? I think it could be a wiper relay (cheapest option) where is it located? does anyone have any ideas, or have had the same problem.

Any help would be apreciated. What a great site!!

wicksy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

wicksy is offline Reply With Quote Quote 
Old 02-05-2008   #2
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 696
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: stilo wipers, front and back not working

Normally would jump straight for the fuses and relay with a chain of componets knocked out and relay T12 is common to both front and rear BUT this also feeds your washers and they're ok so it isn't there where your problem lies.

If you have power to the switch but no power at the motor then, logically, it sounds like you have an open circuit in the wiper switch area, either a poor contact at the wiper switch connector or within the switch itself

At the wiper switch connector A
See if you have power in on pin 11
Earth on Pin 7
front wiper slow speed power should be coming out of pin 8
front wiper fast should be on pin 9

If not then there's a switch internal problem
Click image for larger version

Name:	front wiper switch circuit 1.JPG
Views:	133
Size:	54.3 KB
ID:	42839
Switch is H5
Front wiper is N15
Front washer pump is N22

Hopefully, your pinout for H5 connector A should be like this
Click image for larger version

Name:	H5 wiper switch connector.JPG
Views:	92
Size:	48.4 KB
ID:	42840

See if you have
Earth on Pin 5 connector C

Pinout for H5 connector C
Click image for larger version

Name:	H5 wiper switch connector C.JPG
Views:	56
Size:	42.9 KB
ID:	42841

Worth noting that the washer pump is the same motor for front and back washers, pump polarity direction is just reversed


Also pump earth goes from H5 pin 7 to earth point C10 whereas both wiper motors earth is from H5 pin 5 to earth point C15 CHECK THIS EARTH LINE TOO!
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 02-05-2008 at 11:20.
Deckchair5 is offline Reply With Quote Quote 
Old 02-05-2008   #3
Join Date: Oct 2007
Posts: 5
Thanks: 0
Trader Rating: 0
Re: stilo wipers, front and back not working

Thanks Deckchair 5, what a fountain of info, i wont be able to check this until the weekend, my electrics are not my good point. If it is the switch how easy is it to change? How much do they cost approx?
I done a front wheel bearing last week, that was a bit tricky but the switch looks more difficult.

Cheers Wicksy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

wicksy is offline Reply With Quote Quote 
Old 03-05-2008   #4
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 696
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: stilo wipers, front and back not working

The stalk assembly is 100 or more but they do come up on ebay now and again.

Replacing it means steering wheel and airbag out so I'd advise taking it to a garage if it needs replacing as it's only a 30min job but it could be the last job you ever do if you don't know what you're doing - A lot of people think they know what they're doing and get away with it but the others don't do it twice if you get my drift.

But find out if that IS the problem first as a poor contact there will do the same thing and not cost anything to repair
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 03-05-2008 at 19:51.
Deckchair5 is offline Reply With Quote Quote 
Old 07-05-2008   #5
Join Date: Jun 2004
Location: Ooop North
Posts: 4,724
Thanks: 54
Trader Rating: 0
United Kingdom 
Re: stilo wipers, front and back not working

i had a similar fault, along with other symptoms caused by a faulty earth from the drivers headlight cluster
__________________
2008 Fiat Bravo T-Jet 150 Sport
2014 Fiat 500 S


Fabbrica Italiana Automobili Torino
Big Black Stilo is offline Reply With Quote Quote 
Old 12-05-2008   #6
Join Date: Oct 2007
Posts: 5
Thanks: 0
Trader Rating: 0
Re: stilo wipers, front and back not working

Hi All

I decided to take to Fiat dealer to see if they could find the fault. They say it's the wiper switch and have quoted (are you all sitting down now) 260 inc vat. Is it really that difficult to change, they say 45mins, with the switch being 150.
I asked how much the hourly charge for labour is- 84 was the reply.

Still with this hot weather i dont need the wipers yet.

Still debating if i should have a go myself.

Any more advice appreciated.

Wicksy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

wicksy is offline Reply With Quote Quote 
Old 12-05-2008   #7
Join Date: Jan 2008
Location: Tropical paradise -Luton
Posts: 1,129
Thanks: 86
Trader Rating: 0
United Kingdom 
Re: stilo wipers, front and back not working

Be sure exactly what part you need, but it is probably this.
http://cgi.ebay.co.uk/FIAT-STILO-INDICATOR-SWITCH_W0QQitemZ320249985518QQihZ011QQcategoryZ103 82QQssPageNameZWDVWQQrdZ1QQcmdZViewItem
Buy this and DIY if you are competent at pulling things apart and putting them back together with no bits left over after you have finished.

It is quite likely they have got the diagnosis wrong though.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs


Last edited by john55; 12-05-2008 at 11:22.
john55 is offline Reply With Quote Quote 
Old 12-05-2008   #8
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 696
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: stilo wipers, front and back not working

Have you checked the earth lines from the switch?
You know you have power to the switch as the washers are working. The earth line going to earth C15 is crucial to both front and back wiper motors
Click image for larger version

Name:	front wiper switch wiring earth C15.JPG
Views:	111
Size:	99.8 KB
ID:	43328
See if you can find it as it looks like it's near the battery. Looks like a black match box with, of course black or black/purple wire going in.
Click image for larger version

Name:	front wiper switch circuit 1.JPG
Views:	66
Size:	54.3 KB
ID:	43329
Without C15 giving good line to earth then it's no wiper motors

The ebay item switch John mentioned is one with cruise control, if you haven't got cc then you may be able to find an even cheaper one
Click image for larger version

Name:	whole switch assy.JPG
Views:	52
Size:	71.0 KB
ID:	43330
Here's one without cc
Changing the indicator/wiper switch assembly means steering wheel and air bag out and clock spring securing which is ok if you know what you're doing, life changing hospital experience if you don't

Click image for larger version

Name:	whole switch assy clockspring 2.JPG
Views:	53
Size:	56.2 KB
ID:	43331
Here's the clock spring retaining pin in red

Click image for larger version

Name:	whole switch assy securing bolt 2.JPG
Views:	45
Size:	60.7 KB
ID:	43332
Once you have the steering wheel off then it's a simple single securing screw to loosen the unit and it's off
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 12-05-2008 at 12:24.
Deckchair5 is offline Reply With Quote Quote 
Old 12-05-2008   #9
Join Date: Oct 2007
Posts: 5
Thanks: 0
Trader Rating: 0
Re: stilo wipers, front and back not working

I will check this earth out tonight when i get in. I seem to remember having no live feed at the front wiper motor last week, would the bad earth at the front possibly cause this?

Why do these modern cars have to have all this gadetry, i suppose to try and sell more cars, eg "well my cars got Sat TV,DVD,skyTV,Mobile phone,ejector seat,flame thrower etc,etc,etc"

When you try a sell a car in Autotrader in a few years you will need a whole page to advertise.

Wicksy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

wicksy is offline Reply With Quote Quote 
Old 12-05-2008   #10
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 696
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: stilo wipers, front and back not working

We like gadgets

The switch supplies the live power to the motor (rather than supplying an earth to the motor like the heater fan circuit) and there is a timing relay for the int wipe and a diode inside the switch so plenty to go wrong there


Click image for larger version

Name:	earth C10 and C11.JPG
Views:	76
Size:	118.1 KB
ID:	43335
The earth C10 and C11 depending on whether you're lh or rh drive is also on the hit list which is what BBS had problems with and that's near the front rh headlight apparently
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 12-05-2008 at 12:50.
Deckchair5 is offline Reply With Quote Quote 
Old 12-05-2008   #11
Join Date: Jan 2008
Location: Tropical paradise -Luton
Posts: 1,129
Thanks: 86
Trader Rating: 0
United Kingdom 
Re: stilo wipers, front and back not working

I had a problem with the earth point on the Flitch, left side near the battery. It caused my front wipers to go very slowly and N/S headlamp not to strike, just flicker (Zenon light). Rear wiper was OK though.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

john55 is offline Reply With Quote Quote 
Old 19-05-2008   #12
Join Date: Oct 2007
Posts: 5
Thanks: 0
Trader Rating: 0
Re: stilo wipers, front and back not working

Thanks for all your help and info.

I had to bite the bullet and take to Fiat's, not the best 260 iv'e spent but at least i now have wipers.

It was the switch, just my luck

They also gave me a visual inspection check list (just looking for more work i guess)

All the best Wicksy.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

wicksy is offline Reply With Quote Quote 
Old 21-05-2008   #13
Join Date: Jun 2004
Location: Ooop North
Posts: 4,724
Thanks: 54
Trader Rating: 0
United Kingdom 
Re: stilo wipers, front and back not working

to be honest, as able as i am at times, a job like that i would have taken to fiat to do. I had to get them to find the earth fault causing my wiper problems but cost me nothing
__________________
2008 Fiat Bravo T-Jet 150 Sport
2014 Fiat 500 S


Fabbrica Italiana Automobili Torino
Big Black Stilo is offline Reply With Quote Quote 
Old 11-01-2012   #14
Join Date: Jan 2012
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: stilo wipers, front and back not working

Hi All,
I have read through the thread and found it very helpful. I have a Stilo 1.2; 52 reg with a simmilar sort of problem that started today. The front and rear wipers were fine this morning then stoped working. The front and rear washer is working perfectly fine. I checked the fuse and that was ok. For some reason I left the car for an hour or two and then checked again and the wipers were ok again. Later in the day they stopped.
I have serached through this forum and found very usefull hints and tips, I even used WD40 for the relay fuse box close to the battery and cleaned all the relays and fuses in that location. The wipers started again. But unfortunately now they have stopped working.
I am not sure what else to do? If there are any other connections to check please advise, it will be much appreciated.
Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

abdkaleem is offline Reply With Quote Quote 
Old 26-02-2014   #15
Join Date: Dec 2010
Posts: 79
Thanks: 0
Trader Rating: 0
AbarthGT has donated!
United Kingdom 
Re: stilo wipers, front and back not working

Hi Guys, I know this is an old thread (And I shouldn't be waking up the dead) but I have tested the voltage at pin 11 but no voltage at all the ground at pin 7 is poor as well. Now I need to find out what my next step is to the reason why I have no voltage at pin 11.

When I test the 12V at pin 7 to body ground I get the 12v, but I test the Pin 7 to ground at pin 7 I only get 4.4V Max. Bad Ground I believe? Anything I could do to fix any of these other than wire a whole new ground and voltage source?

Also the rear wiper aren't working either but the washer is working.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs


Last edited by AbarthGT; 26-02-2014 at 19:13.
AbarthGT is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Wipers not working GeoffSt Ducato 0 13-01-2008 20:20
(G) Wipers stopped working b.c Scudo 2 24-02-2007 16:16
(T) wipers not working green goblin Bravo / Brava 5 13-12-2006 11:15
(T) Front wipers stopped working danowat Cinquecento / Seicento 5 10-12-2005 17:41
(T) wipers not working g11ary Punto (Mk2/2b) 19 10-11-2005 18:09