Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 09-07-2009   #1
Join Date: Mar 2009
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
scudo starting problem

Hi guys
I have recently bought a fiat scudo 1.9 el (non turbo) van
When i start the van after it has been left for a few hours, it starts and runs for a few seconds then revs for a second then it stalls. When i then try to start the van it turns over for about 30 seconds before it fires again.
I was thinking maybe a small fuel leak but any advice from you guys would be apreciated
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

jbeany1 is offline Reply With Quote Quote 
Old 11-07-2009   #2
Join Date: Mar 2009
Location: newcastle upon tyne
Posts: 36
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: scudo starting problem

hi
does sound like a fuel problem
try the obvious and check the the clear pipe from the top of the fuel filter that it isnt drawing air bubbles .. you'll see them if you have them
prime the pump manually and see (white arrow)
if so then you could start with getting a new filter that has a new seal kit (o ring)
the top levers of after removing the holding clip (yellow arrow)
do no harm to take this off anyhoo and check the filter
i'm guesing once you fired it up it runs ok tho ?

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

cappas is offline Reply With Quote Quote 
Old 14-07-2009   #3
Join Date: Mar 2009
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: scudo starting problem

Hi cappas
Sorry not to reply any quicker ive only just got my internet connection back online
I have taken the lid off the fuel filter took filter out and put it back together and hey presto starting prob has been fixed fires up straight away and keeps running thanks for your help much apreciated
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

jbeany1 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) scudo problem hopkinsgloria Scudo 4 17-05-2009 17:52
(T) Scudo Starting Problem Help kenny70 Scudo 5 29-04-2009 19:00
(T) scudo starting problem, help needed ruxton30 Scudo 3 25-03-2009 15:40
(G) Scudo 1.9TD hard starting, rough idle, white smoke from exhaust onre Scudo 0 05-08-2007 14:03
(G) none starting scudo schummy10 Scudo 3 19-07-2007 21:12