Register Login
Lamps by Post - For all your lighting needs
Reply
 
Thread Tools
Old 24-07-2017   #1
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
1.2 16v Sporting, fuel pump not running, priming

So I have this mk1 for prob 6 months now, and j haven't touched it, and it only has 47000 miles. But the fuel pump is not running. When I bought car it was and I got a brand new pump for it as the other one sounded Dodge! My question is where is the fuse for the pump, I know where the white relay is and I say it's still that which is the problem, but I'm looking for a bit of advice from someone, here's a pic for ye Click image for larger version

Name:	Snapchat-894891539.jpg
Views:	19
Size:	117.1 KB
ID:	182625
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 01-08-2017   #2
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

Any help at all?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 01-08-2017   #3
Join Date: Jun 2014
Posts: 274
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: 1.2 16v Sporting, fuel pump not running, priming

on the gt the fuel pump fuse is on the cluster on the inner wing , not sure about the sporting may be near the bulkhead above the engine. I'd change the relay and try it , also try the old pump if it was working before , you may have a faulty one . Might be worth changing the rpm sensor on the bottom pulley too
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Steve gt is offline Reply With Quote Quote 
Old 01-08-2017   #4
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

Would the crank sensor stop the pump priming, I have my suspicions about the relay, but I'll have to find one, I've checked every fuse in the car 1 by 1 and there all fine. Fuel cut off is not triggered
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 01-08-2017   #5
Join Date: Jun 2014
Posts: 274
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: 1.2 16v Sporting, fuel pump not running, priming

Don't think the crank sensor would stop the pump priming, it would still fire up once pressure is reached after a few times turning it over .I replaced the relays on mine , got them from the Alfashop
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Steve gt is offline Reply With Quote Quote 
Old 06-08-2017   #6
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

So I got a relay that was starting my Cabrio, same number on top so..... No good, still no pump, I wouldn't mind but the car was backed up into the spot it is in now!
Any other ideas to what to check. I'm going to check if the connector is getting power tomorrow. I'm kinda clueless now
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 08-08-2017   #7
I choose you!
 
blu73's Avatar
Join Date: Nov 2004
Location: Pallet Town
Posts: 16,870
Thanks: 357
Trader Rating: 2
blu73 has donated!
Snowboard Slalom Champion, Skate Boarder Champion
United Kingdom 
Re: 1.2 16v Sporting, fuel pump not running, priming

circuit for the pump is very simple, there is proper wiring diagrams in the downloads section. But if my memory serves for the fuel pump you should have a brown/white wire going from the relay, not sure if it changes colour when it gets to the body connector but it pretty much goes straight from the relay to the pump, and then the ground for the pump is through the inertia switch - not sure exactly where that is on the mk1 but they are usually on the bulkhead inside the car under the dash on most fiats i've ever had to touch one.
Check you have 12v going to the pump when you turn ignition on, check there is an earth on other side. If no earth press inertia switch and try again.

Thats pretty much all there is to the circuit, so it really is simple as it gets wiring wise. You could try putting 12v directly onto the pump just to check that it runs as well.
__________________
Charmander - Panda Mania 1242 mpi 8v - thread
Unnamed - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT
blu73 is offline Reply With Quote Quote 
Old 08-08-2017   #8
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

So I tested the connector today, and it is getting power, and I tested my fuel pump, (keep in mind it is a brand new oem fiat pump) and it isn't working, so now I have 2 dead pumps. Is it possible it could burn out the pump?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 09-08-2017   #9
I choose you!
 
blu73's Avatar
Join Date: Nov 2004
Location: Pallet Town
Posts: 16,870
Thanks: 357
Trader Rating: 2
blu73 has donated!
Snowboard Slalom Champion, Skate Boarder Champion
United Kingdom 
Re: 1.2 16v Sporting, fuel pump not running, priming

is it possible what could burn out the pump?

How did you test the pump?
__________________
Charmander - Panda Mania 1242 mpi 8v - thread
Unnamed - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT
blu73 is offline Reply With Quote Quote 
Old 09-08-2017   #10
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

It's as if the car is burning out the pump from when it is running
I tested the pump with wire and put it on a battery, no luck
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Old 09-08-2017   #11
I choose you!
 
blu73's Avatar
Join Date: Nov 2004
Location: Pallet Town
Posts: 16,870
Thanks: 357
Trader Rating: 2
blu73 has donated!
Snowboard Slalom Champion, Skate Boarder Champion
United Kingdom 
Re: 1.2 16v Sporting, fuel pump not running, priming

Mmmm i doubt the car is killing pumps - the only way i can see it doing that is sending more volts than it should and even then i'd expect the pump to last a while. I think you have just got a dud, or there was a bit of something thats got into it and buggered it up. Should have the bag on bottom to prevent that but I have had one fall off once and some crap in the sender unit got sucked up and killed the pump. But sounds like you have just been unlucky here.
__________________
Charmander - Panda Mania 1242 mpi 8v - thread
Unnamed - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT
blu73 is offline Reply With Quote Quote 
Old 09-08-2017   #12
Join Date: Apr 2015
Posts: 88
Thanks: 3
Trader Rating: 0
Ireland 
Re: 1.2 16v Sporting, fuel pump not running, priming

You see, we bought a heap of fiat parts out of a fiat garage that closed. So the pump it self is genuine, but could be 20 years old...
Youve been a great help blue and Steve gt greatly appreciated. Now I'm going to get the pump out of my parts 75
😂
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Fiatcinquecento is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) fuel pump not priming jonjg Cinquecento / Seicento 5 14-12-2016 17:25
(G) Seicento Sporting 16v fuel pump problem? thoughts please! J.R Racing Cinquecento / Seicento 13 24-04-2016 13:54
(T) Fuel Pump not Priming PhilRogers Punto (Mk2/2b) 6 28-11-2015 20:37
dualogic pump not priming jamieccfc Tech Talk 7 18-12-2014 20:50
fuel pump not running johnny seagull Lets Talk FIAT 0 01-11-2009 19:34