Register Login
Mr. FIAT
Reply
 
Thread Tools
Old 19-10-2008   #1
Join Date: Jan 2008
Location: Ireland
Posts: 37
Thanks: 0
Trader Rating: 0
Ireland 
Interior heater/fan not working!!!

Hi guys,
My 1997 Mk1 SX60 was working perfectly...until today.
I got in, switch the fan on to the number 2 strength... and no air comes outt! It will only work if I put it to number 3 (which blasts air at me and is noisy!!!).
I can't get it to a mechanic til Saturday, has anyone any advice on what I can do?
I haven't done ANYTHING wrong. Only thing that's strange is the gales we had all last night but that shouldn't make any difference to a car!!!!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

niamhh is offline Reply With Quote Quote 
Old 19-10-2008   #2
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,442
Thanks: 640
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Interior heater/fan not working!!!

Hi,

its likely that your resistor pack has gone. Its very common on the Mk1. You will need to replace the resistors. I also recommend checking the condition of the fan motor before you replace the resistors, as they normally go when the fan has stiffened up or has got wet.

For the time being, it will be fine just to run it at speed three untill you can get it fixed.

Hope that helps,
Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 19-10-2008   #3
Join Date: Mar 2007
Posts: 36
Thanks: 0
Trader Rating: 0
Re: Interior heater/fan not working!!!

got similar problem with mk2 punto heater fan wont blow and if you switch it to high side lights come on?
yours gb
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

geoff b is offline Reply With Quote Quote 
Old 19-10-2008   #4
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,442
Thanks: 640
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: Interior heater/fan not working!!!

Hi mate,

Tis a common problem on the punto mk2. will take 10 mins to fix.

Have a look HERE ... even has pics on how to fix it.

Hope that helps,
Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 19-10-2008   #5
Join Date: Jan 2008
Location: Ireland
Posts: 37
Thanks: 0
Trader Rating: 0
Ireland 
Re: Interior heater/fan not working!!!

Hi, where would I get replacement resistors?
Would I get them in a car accessories shop?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

niamhh is offline Reply With Quote Quote 
Old 19-10-2008   #6
Polar Opposites
Join Date: Apr 2008
Location: Cheadle Staffs/Luf Leics
Posts: 1,537
Thanks: 90
Trader Rating: 0
5abr3 has donated!
United Kingdom 
Re: Interior heater/fan not working!!!

Scrap yard is the best bet!
__________________
My car pictures thread

Quote Originally Posted by TurboSei View Post
Anyway. Enough chatter, more arse action!
5abr3 is offline Reply With Quote Quote 
Old 21-10-2008   #7
Join Date: Oct 2008
Location: South Wales
Posts: 903
Thanks: 21
Trader Rating: 0
BrumBrum has donated!
United Kingdom 
Re: Interior heater/fan not working!!!

Glad I found this thread, Same things wrong with my MK1, Not a big problem but it would be nice to demist the car and still hear the stereo lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

BrumBrum is offline Reply With Quote Quote 
Old 24-10-2008   #8
Join Date: Jan 2008
Location: Ireland
Posts: 37
Thanks: 0
Trader Rating: 0
Ireland 
Re: Interior heater/fan not working!!!

Would I be able to order the parts in Halfords and does anyone know the specs for the correct resistor for the Mk1 SX60? Is there some sort of Fiat part nuimber for it?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

niamhh is offline Reply With Quote Quote 
Old 25-10-2008   #9
Polar Opposites
Join Date: Apr 2008
Location: Cheadle Staffs/Luf Leics
Posts: 1,537
Thanks: 90
Trader Rating: 0
5abr3 has donated!
United Kingdom 
Re: Interior heater/fan not working!!!

Halfords wont know what your talking about, you need to try a motor factors if you want new, or FIAT, I'l see if I can find the part number on ePER but I wouldn't hold your breath!
__________________
My car pictures thread

Quote Originally Posted by TurboSei View Post
Anyway. Enough chatter, more arse action!
5abr3 is offline Reply With Quote Quote 
Old 27-03-2009   #10
Join Date: Mar 2009
Location: Camberley
Posts: 7
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Interior heater/fan not working!!!

Quote Originally Posted by a1ant View Post
Hi,

its likely that your resistor pack has gone. Its very common on the Mk1. You will need to replace the resistors. I also recommend checking the condition of the fan motor before you replace the resistors, as they normally go when the fan has stiffened up or has got wet.

For the time being, it will be fine just to run it at speed three untill you can get it fixed.

Hope that helps,
Alan
Hi Alan,

When you say that the resistor pack has gone, is this built into the heater switch?
Can it be overhauled or do you have to replace for new unit?
Either way, do you know how to remove the switch from the dash?

Thanks in advance
J.
__________________
Punto 85 SX (1998)
jeremyfindlay is offline Reply With Quote Quote 
Old 14-06-2012   #11
Join Date: May 2012
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Hi I have had the same problem with my mk2b
The matrix fan under the passenger under the govebox there is a brown plastic connecter you unscrew nut and there is a resister pack test the connection cause it could mean all of the resister have gone or one this mean earth problem they are 28 pound for fiat or you can fix it by getting a wire crip the wire to the connector and screw it to the body of the car and the other end into the black connecter.

Thanks

Chris
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

djchris is offline Reply With Quote Quote 
Old 14-06-2012   #12
Join Date: May 2012
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by niamhh View Post
Hi, where would I get replacement resistors?
Would I get them in a car accessories shop?
Hi the best bet is fiat dealership they are about 28 quid or eBay
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

djchris is offline Reply With Quote Quote 
Old 22-12-2012   #13
Join Date: Dec 2012
Location: Leeds
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Thumbs up Re: Interior heater/fan not working!!!

I came across this forum whilst looking for an answer to my interior heater/fan not working problem. I would just like to say, that I have followed the advice given and managed to find and solve the problem with my heater - thank all!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

LyndaLynda is offline Reply With Quote Quote 
Old 22-12-2012   #14
Join Date: Dec 2012
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Interior heater/fan not working!!!

do you regularly park under a tree?

i did and got loads of old dead leaves trapped in the drainage bit under where the wipers go, un do that and have a quick look see if there is crap in there, sorted mine out!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

tomgoodeve is offline Reply With Quote Quote 
Old 22-12-2012   #15
Mk1 Punto Mod
 
blu73's Avatar
Join Date: Nov 2004
Location: Danger Zone!
Posts: 14,006
Thanks: 241
Trader Rating: 1
blu73 has donated!
Snowboard Slalom Champion
United Kingdom 
Re: Interior heater/fan not working!!!

welcome to FF @LyndaLynda

yet another new member from Yorkshire
__________________
FIAT-LESS

Suzuki Ignis Sport
Suzuki Ignis Sport
blu73 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Interior Heater Fan littlericharduk Bravo / Brava 3 26-11-2007 09:05
(T) JTD heater fan not working. SquarePeg Punto (Mk2/2b) 1 19-10-2007 08:31
(T) Heater fan only working on no: 4 andy1312 Multipla 3 10-10-2007 12:29
(G) My heater fan has stopped working mikeypunto Punto (Mk2/2b) 2 08-08-2006 23:28
(T) Heater Fan working erratically QuickNick Bravo / Brava 0 03-07-2006 08:52