Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 1 Week Ago   #1
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
EML on without error code

So my EML just came on this morning, after about 5 minutes of driving. I had just been at a stop, as I needed to pull out onto another road, when it turned on. The car was then turned off at the petrol station and once I got to work. I scanned it 10 minutes ago with MES, no code. Tried starting the car - EML still on, but no code registered. Where do I start? There's no noticeable difference in driving at all.
How do I clear the light when there's no code to delete? Disconnect battery for 10 minutes?
Thanks irc thanked for this post
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #2
Join Date: Mar 2011
Posts: 7,375
Thanks: 530
Trader Rating: 0
Mexico 
Re: EML on without error code

weird
__________________
s and b is offline Reply With Quote Quote 
Old 1 Week Ago   #3
Join Date: Oct 2014
Location: West Yorkshire
Posts: 777
Thanks: 20
Trader Rating: 0
United Kingdom 
Re: EML on without error code

Could be an electrical issue... have you tested other modules on mes to see its all working fine?
__________________
Current car: 06 Fiat Stilo Sporting 150 Multijet
Past cars: 03 Stilo 1.2 Active 16v, 06 Focus 1.4 LS, 98 E36 323is, 97 Astra 1.6, 95 Astra 1.7 TDI, 95 Micra Super S, 96 Almera 1.6 GX, 94 Micra Super S, 97 Vectra 1.6 Envoy, 98 A4 1.8T Sport
dtimmins1985 is offline Reply With Quote Quote 
Old 1 Week Ago   #4
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,384
Thanks: 186
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: EML on without error code

What engine?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is online now Reply With Quote Quote 
Old 1 Week Ago   #5
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,384
Thanks: 186
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: EML on without error code

If you connect to the ECU with MES you can turm the failure light on and off from the "Actuators" tab (F6). This will at least rule out a failure in the light electronics or wiring.

Robert G8RPI
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is online now Reply With Quote Quote 
Old 1 Week Ago   #6
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

1.2 8v. I'll try have a look at the actuators tomorrow.
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #7
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

So I have now tried with both my ELM327 and VAG KKL, to activate the EML in the dash - both times it said "Failed to execute". Just started my car, and it's now revving 2000-4000rpm by itself... I have literally only done the above.
I have disconnected the battery just now, to try and see if this clears it.

EDIT: Battery reconnected and car no longer revs by itself. However the EML is still on...
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)

Last edited by brinker; 1 Week Ago at 06:58.
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #8
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,384
Thanks: 186
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: EML on without error code

Hi,
You need to check the battery and engine earth leads, ECU mounting earth and ECU connectors for corrosion or loose connections. Have a good look at other connectors and wiring looms for water,ingress chafing or other damage.

Robert G8RPI.
Thanks brinker thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is online now Reply With Quote Quote 
Old 1 Week Ago   #9
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

Thanks Robert. I'll have a look around the engine bay. Not sure I'll get around to it before Friday, but we'll see. Will keep you posted.
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #10
Join Date: Oct 2014
Location: West Yorkshire
Posts: 777
Thanks: 20
Trader Rating: 0
United Kingdom 
Re: EML on without error code

Sounds like you didnt get a connection to the ecu with your cables...

Have you set the latency correctly in windows, are you using latest drivers for the ftdi chip / usb serial port.
__________________
Current car: 06 Fiat Stilo Sporting 150 Multijet
Past cars: 03 Stilo 1.2 Active 16v, 06 Focus 1.4 LS, 98 E36 323is, 97 Astra 1.6, 95 Astra 1.7 TDI, 95 Micra Super S, 96 Almera 1.6 GX, 94 Micra Super S, 97 Vectra 1.6 Envoy, 98 A4 1.8T Sport
dtimmins1985 is offline Reply With Quote Quote 
Old 1 Week Ago   #11
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

If it didn't connect, it would tell me it didn't connect. It connects just fine, and all parameters are working. I've been using this setup with my ELM cable for several years now, without any issues - and have previously read out error codes and cleared engine lights on this.
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #12
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

I went through connecters and wiring yesterday, everything looked fine. Removed and cleaned throttle body (as I hadn't done so for a while), wire brushed surface betwwen TB and ECU. Let engine idle and went out into engine bay and moved around connectors and wiring to see if it would trip anything - but just kept going like nothing happened.

A colleague of mine will bring his test equipment tomorrow, hope maybe this shows an error code, but I kinda doubt it by now...

Additional info: Battery voltage ACC 12.1V - Battery voltage ON 13.6V
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)

Last edited by brinker; 1 Week Ago at 08:27.
brinker is offline Reply With Quote Quote 
Old 1 Week Ago   #13
Join Date: Mar 2015
Posts: 449
Thanks: 6
Trader Rating: 0
brinker has donated!
Denmark 
Re: EML on without error code

My colleagues test equipment showed a stored P0130 (Lambda 1 circuit malfunction). I've deleted it for now and my EML is off again. Hopefully doesn't come back - otherwise my O2 sensors are only 8 months old, so should be covered by warranty.
__________________


Personal Best Lap Times:
Circuit Park Zandvoort - 2:37.89 (Fat Amy @??BHP)
brinker is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
code error Lia Joseph I.C.E 0 24-04-2015 13:57
(T) Multijet EML Light on!!! (Fault code P0234) captain peebody Qubo 6 27-02-2014 22:28
Error code Shazza Stilo 17 18-03-2012 12:15
(T) Error code honda Grande Punto 3 16-07-2010 21:45
(G) Fault code / Error code list sporn Punto (Mk2/2b) 2 12-05-2010 16:49