Register Login
iNETFX Domain Registration - COM/NET/ORG 6.50 a year!
Reply
 
Thread Tools
Old 02-10-2012   #1
car noob
Join Date: Sep 2011
Posts: 102
Thanks: 0
Trader Rating: 0
tomrw has donated!
United Kingdom 
"Automatic Transmission Warning Light?"

I have a W Reg 1.2l Speedgear punto which I've spoken about before. Normally when I'm in traffic I shift from Drive to Neutral so theres no stress on the car.

Anyway the 'LCD' screen didn't show that the transmission was in "D" or "N" so when I shifted back into drive this warning light was flashing on the bottom left hand side of the dash. It sorta looks like a car boot which Ive googled and it seems to be 'Automatic Transmission Failure' warning light.

The car however, is still moving. I turned the engine off, and restarted it and it still appeared. When I got home I shifted into every option and the light disappeared just like that. Obviously it could have been an earthing fault (so i've read) maybe I'm not sure and I'm not 'that' technical but the car seems to be running fine.

Does anyone have an idea what this could be?

Also I have FES but which cable do I need to be able to read the fault code for it? I only have the cable to proxy align /edit odometer.

Thanks!
__________________
tomrw is offline Reply With Quote Quote 
Old 02-10-2012   #2
Join Date: Apr 2008
Posts: 12,274
Thanks: 597
Trader Rating: 0
Ziggy122 has donated!
Egg Catcher Champion, Eggs Champion, Fruit Pairs Champion
United Kingdom 
Re: "Automatic Transmission Warning Light?"

Try cleaning both sets of rear light connectors on the light clutster and multi-plug

And then see what happens

often these connectors go funny - and as a result confuse the gearbox's alot....

Ziggy
Likes homeward liked this post
__________________
Ziggy122 is offline Reply With Quote Quote 
Old 02-10-2012   #3
will do anything for cash
 
dave's Avatar
Join Date: Aug 2003
Location: Essex/Suffolk border
Posts: 80,525
Thanks: 1416
Trader Rating: 10
dave has donated!
dave is an official FF Advertiser
dave is an honorary friend of the forum :)
United Kingdom 
Re: "Automatic Transmission Warning Light?"

if its the eartt fault you should hear the gate clicking on gear leaver when braking
Likes homeward liked this post
__________________
Please do not Email or PM me asking for support. Post on the forums instead. Your reply may help someone else. Thank you.
Will Do Moose Stuff For Money
dave is offline Reply With Quote Quote 
Old 02-10-2012   #4
The Bard of Tysoe
 
homeward's Avatar
Join Date: May 2012
Location: On the hard shoulder...
Posts: 6,160
Thanks: 325
Trader Rating: 1
homeward is part of the official FF Events Team :)
homeward has donated!
homeward is an honorary friend of the forum :)
United Kingdom 
Cool Re: "Automatic Transmission Warning Light?"

Quote Originally Posted by dave View Post
if its the eartt fault you should hear the gate clicking on gear leaver when braking
You might also get the gearbox 'beeping' when you brake... -- which is what happened to me.... @Ziggy122's suggestion of cleaning the terminals on your rear lights is a good first step... -- it certainly cured mine... (and you'd be amazed how much crud can collect in there...)!
__________________

1990 Panda 750L Formula '90: Pippin (26,131 miles; 47.18 mpg)
2009 Panda 1.2 Eleganza Dualogic: Pandora (55,670 miles; 47.87 mpg)
2002 Punto 1.2 16v ELX Speedgear: Priscilla (100,465 miles; 41.30 mpg)
homeward is offline Reply With Quote Quote 
Old 04-10-2012   #5
car noob
Join Date: Sep 2011
Posts: 102
Thanks: 0
Trader Rating: 0
tomrw has donated!
United Kingdom 
Re: "Automatic Transmission Warning Light?"

Cheers for the replies guys.

Where abouts exactly are these connectors etc?
What do I use to clean them? Connector cleaner from halfords or wherever?

Got in the car this morning and the light came back on again but went off when i did the same thing.

When I put my foot on the brake I did hear the clicking but no 'beeping'?
__________________
tomrw is offline Reply With Quote Quote 
Old 04-10-2012   #6
The Bard of Tysoe
 
homeward's Avatar
Join Date: May 2012
Location: On the hard shoulder...
Posts: 6,160
Thanks: 325
Trader Rating: 1
homeward is part of the official FF Events Team :)
homeward has donated!
homeward is an honorary friend of the forum :)
United Kingdom 
Re: "Automatic Transmission Warning Light?"

Quote Originally Posted by tomrw View Post
Where abouts exactly are these connectors etc?
What do I use to clean them? Connector cleaner from halfords or wherever?
You need to take off the rear light clusters... -- particularly the one with the reversing light (on the nearside, on my Punto...). The (rather strangely-shaped) 'nuts' for this are:
  1. in the boot (behind the lining -- there should be a cut-out: but you will also need to remove the factory-fitted subwoofer, if you have one...); and
  2. on the rear pillar (there's a 'flap' in the plastic -- near to the seatbelt mounting point -- which you need to remove with a small, flat-bladed screwdriver).
[If you have the owner's handbook, it's much better explained in there...! See also these photos, posted by @Ziggy122; and this thread....]

These 'nuts' can be removed with either the special tool in the spare-wheel kit in the boot (which should also contain the screwdriver...); or -- if they're tight, as mine were -- start off with the wrench you'd use for the wheel nuts.

The cluster then pulls away from the back of the car (usually with a load of dirt -- which is the cause of the problem; and needs removing...); followed by the wiring. Disconnect this; and it's the terminals on the light that go into this block that are the cause of the clicking (or, in my case, beeping). These need cleaning until they are all nice and shiny...!

I used fine wet-and-dry paper, a Brillo pad, and some WD40. The "small, flat-bladed screwdriver" may also come in useful, when scraping off any oxidization.... (And I should probably have smeared some Vaseline, etc. on them, when putting everything back....)

Hope this helps...!
__________________

1990 Panda 750L Formula '90: Pippin (26,131 miles; 47.18 mpg)
2009 Panda 1.2 Eleganza Dualogic: Pandora (55,670 miles; 47.87 mpg)
2002 Punto 1.2 16v ELX Speedgear: Priscilla (100,465 miles; 41.30 mpg)
homeward is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Get rid of..."Change Engine Oil" warning light! r0r Newbie Central 1 24-06-2013 00:00
(T) Injection System Warning Light and "Engine Check" Message scotlandstopboy Punto (Mk2/2b) 8 10-01-2010 00:51
(T) ABS & Automatic Transmission warning light evo7mc Punto (Mk2/2b) 0 12-07-2009 17:25
(G) "Lights Check" Dashboard Warning Light gethers Punto (Mk2/2b) 8 02-08-2006 23:21