Register Login
Lamps by Post - For all your lighting needs
Reply
 
Thread Tools
Old 07-06-2009   #1
Join Date: Jun 2009
Location: Manchester
Posts: 9
Thanks: 0
Trader Rating: 0
United Kingdom 
P0170

Hi to everyone as this is my first post. I have got a 54 plate punto 1.2 8V now just recently it has been running really poor. It starts all the time but always try's to cut out. I recently had it on a code reader and the map sensor & lambda sensors came up so they have been replaced. I am still getting P0170 on the code reader which is fuel trim bank 1 fault. I have now been told that this could be the ECU. Is this correct and is it just a case of buying a replacement or will I need anything else I have been told to replace the coils aswell. Any help would be appreciated as this is now doing my head in.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

damosmokie is offline Reply With Quote Quote 
Old 07-06-2009   #2
Join Date: Apr 2008
Posts: 115
Thanks: 6
Trader Rating: 0
Re: P0170

I'm no expert but perhaps your ECU would benefit from being given a bit of a reset which, as far as i know just involves disconnecting the negative battery lead and leaving it off for a good while. Not sure how long, maybe a search on here would tell?

There are lots of people on here with more experience than me regards Diagnostics who will be able to advise you better but...how does this sound...

If the Long Term Fuel Trim has been falsely altered through a poor O2 sensor, maybe by resetting the ECU as above, the ECU can now begin to use imputs from various sensors again. Just a thought

Let us know how you get on mate please.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

shaun2007 is offline Reply With Quote Quote 
Old 07-06-2009   #3
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Glasgae
Posts: 30,007
Thanks: 1045
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: P0170

monitor your 'upstream' lambda sensor.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump