Register Login
iNETFX Domain Registration - COM/NET/ORG 6.50 a year!
Reply
 
Thread Tools
Old 26-03-2009   #1
Join Date: Mar 2008
Posts: 172
Thanks: 5
Trader Rating: 0
kipster1 has donated!
United Kingdom 
Heater blower only working on setting 4.

As title, anybody have any ideas please?
Setting 1,2,3, no longer work,
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

kipster1 is offline Reply With Quote Quote 
Old 26-03-2009   #2
Join Date: Nov 2008
Location: London
Posts: 201
Thanks: 13
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

It may be that your fan bearings require cleaning/lubrication. Its possible that only setting 4 gives enough power to make fan actually turn.

There was a recent thread with similar issue on this forum.
__________________
2012 - Toyota Auris Hybrid 1.8 T-Spirit
2008 - Fiat Panda Multijet 1.3 Dynamic
- R.I.P.
Ingvarr is offline Reply With Quote Quote 
Old 26-03-2009   #3
Join Date: Mar 2008
Location: Andover
Posts: 1,391
Thanks: 40
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

Another possibility is the heater resistor pack has failed (which will likely be by-passed on position 4)....

Chris
__________________
Holding up the traffic in a little Italian.........
ScoobyChris is offline Reply With Quote Quote 
Old 26-03-2009   #4
Yellow is the way to go!
 
Wee Smurf's Avatar
Join Date: Aug 2005
Location: Belfast
Posts: 2,479
Thanks: 71
Trader Rating: 0
Wee Smurf has donated!
Tritryst Champion, Retro Pairs 3 Champion, Retro Pairs Champion, Retro Pairs 2 Champion
United Kingdom 
Re: Heater blower only working on setting 4.

Quote Originally Posted by ScoobyChris View Post
Another possibility is the heater resistor pack has failed (which will likely be by-passed on position 4)....

Chris
I'd say it was the resistor. Resistor failed and was replaced so many times on my old Polo. Strangely it's gone again, so another trip to the scrappy required.
__________________
The Northern Ireland Italian Motor Club. Find us at: http://www.niimc.net.
We meet on the first Tuesday of the month at the Lisburn Golf Club (near Sprucefield roundabout) at 7:45pm.
Please note we've moved to a new venue.
Come along - All Italian motors welcome. PM me for more details.
Wee Smurf is offline Reply With Quote Quote 
Old 26-03-2009   #5
sdb-punto's evil twin
 
1383matt's Avatar
Join Date: Mar 2008
Location: norwich
Posts: 769
Thanks: 43
Trader Rating: 0
1383matt has donated!
United Kingdom 
Re: Heater blower only working on setting 4.

if its like a punto,then resistor gone. my resistor went and i got a new one direct from fiat for 12
__________________
1383matt is offline Reply With Quote Quote 
Old 26-03-2009   #6
Join Date: Jan 2008
Location: County Durham
Posts: 192
Thanks: 10
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

I bypassed the resistor altogether on an old M reg Punto just out of curiousity - it was obviously burnt out - and the fan resumed working properly on all speeds, so how did that work?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Trimdoner is offline Reply With Quote Quote 
Old 26-03-2009   #7
Join Date: Mar 2008
Posts: 172
Thanks: 5
Trader Rating: 0
kipster1 has donated!
United Kingdom 
Re: Heater blower only working on setting 4.

Thanks for the help, where do i find the resistor pack??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

kipster1 is offline Reply With Quote Quote 
Old 27-03-2009   #8
Join Date: Mar 2008
Posts: 172
Thanks: 5
Trader Rating: 0
kipster1 has donated!
United Kingdom 
Re: Heater blower only working on setting 4.

Thanks for help so far, but can anyone point me in the direction of where the resistor block is?

Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

kipster1 is offline Reply With Quote Quote 
Old 28-03-2009   #9
Join Date: Mar 2008
Posts: 172
Thanks: 5
Trader Rating: 0
kipster1 has donated!
United Kingdom 
Re: Heater blower only working on setting 4.

Ooooops!

Sorry for double post above, too much beer last night .

Cant remember posting first time!

Is this the resistor pack ? Thanks in advance.

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

kipster1 is offline Reply With Quote Quote 
Old 28-03-2009   #10
Join Date: Jan 2008
Location: County Durham
Posts: 192
Thanks: 10
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

Almost identical to the M reg Punto. The little resistor on the end was the bit burnt out on that - I relaced it with a bit of fuse wire.
Attached Images
 
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs


Last edited by Trimdoner; 28-03-2009 at 11:53.
Trimdoner is offline Reply With Quote Quote 
Old 28-03-2009   #11
Join Date: Mar 2008
Posts: 172
Thanks: 5
Trader Rating: 0
kipster1 has donated!
United Kingdom 
Re: Heater blower only working on setting 4.

I will have a closer look.

Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

kipster1 is offline Reply With Quote Quote 
Old 29-03-2009   #12
Join Date: Dec 2007
Location: North Herts
Posts: 1,230
Thanks: 145
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

The little component that sits on the top of the green block is a 'thermal fuse' rather than another resistor. If the whole green unit gets too hot, this 'fuse' fails (by melting inside)... which is why, Trimdoner, it worked on all speeds once you'd bypassed it. However, note that 'next time' you have no thermal overload protection so something else will burn instead!

Pete
__________________
2013 Panda 4x4 :: North Herts :: Remember, if you find a post helpful, press the smiley face 'thanks' button below
Herts Hillhopper is offline Reply With Quote Quote 
Old 29-03-2009   #13
Join Date: Jan 2008
Location: County Durham
Posts: 192
Thanks: 10
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

Quote Quote:
you have no thermal overload protection so something else will burn instead!
At least I know now not to do it on my own car

It was a couple of years ago on an old Punto my daughter bought - it's long since gone, scrapped after failing its MOT on too many things. Luckily it didn't catch fire before it went!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Trimdoner is offline Reply With Quote Quote 
Old 04-09-2010   #14
Join Date: Sep 2010
Posts: 1
Thanks: 0
Trader Rating: 0
Serbia 
Re: Heater blower only working on setting 4.

Quote Originally Posted by Herts Hillhopper View Post
The little component that sits on the top of the green block is a 'thermal fuse' rather than another resistor. If the whole green unit gets too hot, this 'fuse' fails (by melting inside)... which is why, Trimdoner, it worked on all speeds once you'd bypassed it. However, note that 'next time' you have no thermal overload protection so something else will burn instead!

Pete
Do you know the temperature for that thermal fuse on Punto (MK2)? Is it 216 degrees or some other (maybe part number if you have it)?

Thanks in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

vladamar is offline Reply With Quote Quote 
Old 04-09-2010   #15
Join Date: Jan 2009
Location: herts
Posts: 33
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Heater blower only working on setting 4.

You will probably have the temperature printed on the body, but it will be hard to read if it has 'burnt'. Try cleaning it with water first, followed by a very light abrasive eg toothpaste. You should then be able to read it!

Spares can be had from Maplin
http://www.maplin.co.uk/Module.aspx?ModuleNo=470
at the princely sum of 79p !

However you will have to fit the new one without overheating by soldering. If you can leave enough of the old legs use connectors from a a 1A chocalate block.

IIRC in my Picasso the old one was 144degC and I replaced with 152 degC. But in that car the resister pack is in the airflow of the fan so ifor yours it maybe a higher/lower value .
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

pmh is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
heater blower control not working wiganlad Newbie Central 2 21-04-2010 13:39
(T) heater blower switch not working ...help me plzz djmacca Punto (Mk2/2b) 5 22-03-2008 20:47
My heater blower aint working voodoo55 Newbie Central 2 13-11-2006 00:09
(G) Heater Only Working On 1 Setting. fiatbravaross Bravo / Brava 5 23-12-2005 18:33
(T) Heater blower not working craig20vturbo Coupe 3 19-12-2005 21:40