Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 10-07-2016   #1
Join Date: Sep 2014
Posts: 24
Thanks: 0
Trader Rating: 0
United Kingdom 
Helppp :(

So for the past few weeks, sometimes when i start my agp on cold it struggles to start a bit and just splutters for about 2 seconds and once started when it sits just above 1k rpm (when its warming up) it shakes :/ and yesterday i started her up cold again and it struggled again, but then once it was running it sounded funny and sounded like it was struggling and the engine light check started flashing for about 10 seconds..
Any idea what this is? Any help highly appreciated!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Patrick S5 is offline Reply With Quote Quote 
Old 10-07-2016   #2
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,576
Thanks: 541
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Helppp :(

Quote Originally Posted by Patrick S5 View Post
So for the past few weeks, sometimes when i start my agp on cold it struggles to start a bit and just splutters for about 2 seconds and once started when it sits just above 1k rpm (when its warming up) it shakes :/ and yesterday i started her up cold again and it struggled again, but then once it was running it sounded funny and sounded like it was struggling and the engine light check started flashing for about 10 seconds..
Any idea what this is? Any help highly appreciated!!
Hi,

any rough running generally indicated that 3 or less cylinders are firing,
when were the plugs last changed,

how many miles on car..? what oil is in it..?? the Multiair unit can also cause similar issues.
although yours sounds more basic - if it had improved as the engine warmed-up.

personally ; I'd get the plugs out - and see what state they are in.. looking for differences in burn residue colour

then run it again, if there is another hesitation ..get the current AND STORED fault codes read.,
Charlie - Oxford
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 10-07-2016   #3
Join Date: Sep 2014
Posts: 24
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Helppp :(

Thanks for the quickquick reply!

So the car had a service at an Abarth place in Willenhall 2 months ago so they should of been changed then but in all fairness I think they never changed half of the stuff they were meant to...When I was picking it up from them the car was left in sport and an extra 5 miles was on the clock so I won't be going back there!
I don't know what oil is in there tbh, the mileage is at nearly 56k. I dont think mine is a multiair, agps are t jet? I really dont know tbh but I'll have a look at the spark plugs

Thanks for your help!
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Patrick S5 is offline Reply With Quote Quote 
Old 10-07-2016   #4
Join Date: Sep 2014
Posts: 24
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Helppp :(

Yeah so all sparkplugs do seem to be new and i checked the coil packs and they all get a spark?I'll check again tomorrow morning see if it happens again but any idea why the car has started to shake/vibrate when its warming up at 1250rpm? Its been doing it for the past couple of weeks and ive had the car nearly a year and it never done that?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Patrick S5 is offline Reply With Quote Quote 
Old 10-07-2016   #5
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,576
Thanks: 541
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Helppp :(

Quote Originally Posted by Patrick S5 View Post
Yeah so all sparkplugs do seem to be new and i checked the coil packs and they all get a spark?I'll check again tomorrow morning see if it happens again but any idea why the car has started to shake/vibrate when its warming up at 1250rpm? Its been doing it for the past couple of weeks and ive had the car nearly a year and it never done that?
obvious thing is running on less than 4 cylinders.. that'll bring on the EML

a @10 code reader can get the error codes from that ( probably misfire detected)

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 10-07-2016   #6
Join Date: Sep 2014
Posts: 24
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Helppp :(

Thanks, don't suppose you got a link of said code reader? Or know which one I need?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Patrick S5 is offline Reply With Quote Quote 
Old 10-07-2016   #7
Join Date: Apr 2011
Location: Oxford - UK
Posts: 15,576
Thanks: 541
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Helppp :(

Quote Originally Posted by Patrick S5 View Post
Thanks, don't suppose you got a link of said code reader? Or know which one I need?
they ALL do engine codes - that's the industry standard "OBD2"

better kit does airbags, ABS etc

look on EBAY ,http://www.ebay.co.uk/itm/Vgate-Scan...4AAMXQNo5TbowK is good value for it's range of features,
but you can get them from @8 to do the basics.


shame you're not nearer , or I'd demo the MultiECUScan

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 31-07-2016   #8
Join Date: Jun 2015
Posts: 109
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Helppp :(

Quote Originally Posted by Patrick S5 View Post
Thanks for the quickquick reply!

So the car had a service at an Abarth place in Willenhall 2 months ago so they should of been changed then but in all fairness I think they never changed half of the stuff they were meant to...When I was picking it up from them the car was left in sport and an extra 5 miles was on the clock so I won't be going back there!
Motor Mech in Birmingham have just had my Stilo for a service. They're not finished with it as it needs more work but I was very happy with them. I won't be taking my car anywhere else in a hurry.

Good location as well. If you want to leave your car with them and go shopping or commute back out, they are literally a couple of metres from Moor St/Bullring car park.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Edwardo85 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Helppp yas135 Newbie Central 0 07-06-2011 19:33
(G) Helppp SamC RAGE Punto (Mk1) 3 05-09-2010 22:08
(T) Helppp!!! craig67 Punto (Mk2/2b) 9 03-02-2010 12:12
Helppp ! puntogt1 Tech Talk 0 02-01-2010 00:09
Helppp !!!!!!!!!!!! GP1416valver Blue and Me 3 02-04-2009 22:02